Previous: Saving JNLP Files Next: Using Favorite Bundles Table of contents Index Glossary Images Frames U09-NRM-127: The role of Distributed Data Access Technologies in NRM - for ITC-IDV version 2.7 > Accessing and Displaying Data > Saving State and Views

4.4.3 The Default Bundle
You can create a default IDV state and save it off using the bundle facility.
  1. By default the IDV imports a Default bundle when it starts up.
  2. If other displays and data are already loaded, select the Edit->Remove All Displays and Data menu item or the icon in the toolbar to clear them out.
  3. Open up a new view window with the File->New->View Window menu item.
  4. Change its state.
  5. Save the current state as the default bundle by selecting the File->Default Bundle->Save menu item from the main menu bar.
  6. This file is saved in the user's local resource directory:
    <home directory>/.metapps/DefaultIdv
    (e.g., /home/idv/.metapps/DefaultIdv) as default.xidv.
  7. Exit the IDV and restart it. You should see the previously saved state.
  8. Remove all data and displays.
  9. Select the File->Default Bundle->Open menu item or the button from the toolbar to reload the bundle.
  10. Delete the default bundle with the File->Default Bundle->Remove menu item from the main menu bar.
  11. Exit the IDV and restart it. You should see the previously saved state defined in your user preferences.

 


Previous: Saving JNLP Files Next: Using Favorite Bundles Table of contents Index Glossary Images Frames Français Español Portugese Italian Japanese Korean Russian Chinese-simp Chinese-trad Dutch German Greek Français Español Portugese Italian Japanese Korean Russian Chinese-simp Chinese-trad Dutch German Greek

U09-NRM-127: The role of Distributed Data Access Technologies in NRM - for ITC-IDV version 2.7 > Accessing and Displaying Data > Saving State and Views