Previous: Navigating (Zooming, Panning and Rotating) the View Window Next: The View and Projections Menus Table of contents Index Glossary Images Frames U09-NRM-127: The role of Distributed Data Access Technologies in NRM - for ITC-IDV version 2.7 > Starting the IDV/GUI Basics > IDV Basic Concepts

3.1.2 The Main IDV Menu
In this exercise, we explore some of the items in the main menu bar of the IDV.

The main menu bar is accessible from either the View Window or the Dashboard window. Detailed information on each item in the main menu bar can be found in the IDV User's Guide.

For this exercise, we will look at the File and Help menus. The other menus will be explored in subsequent exercises.
The File Menu
The File menu is used for opening new View Windows, restoring the Dashboard, importing and exporting bundles and exiting the IDV. As a simple exercise, we will close the Dashboard and then open a new one, since this is a common function.
  1. Close the Dashboard window by clicking on the X in the title bar of the window.
  2. Open a new Dashboard by selecting the File->New->View Window->Windows->Dashboard menu item.
  3. You can have multiple view windows open at the same time. Open a new View Window by selecting the File->New->View Window->Map View->One Pane menu item. Open a two pane Globe Display.
  4. Close these new View Windows by clicking the X in the upper right corner.
We'll look at other portions of the File menu in subsequent exercises.
The Edit Menu
The Edit menu can be used to clear out displays and data sources as well as access the formula editor and user preferences.
  1. First, let's clear out all the displays we have loaded. Select the Edit->Remove All Displays menu. All the displays except for the map should be removed from the view.
  2. In the Field Selector, notice that the data source is still listed. We could create new displays from that data source if we wanted, but lets clear it out. Select the Edit->Remove All Data Sources menu to remove the data source.
  3. You could have accomplished the 2 steps above in one action by clicking the Edit->Remove All Displays and Data menu.
The Help Menu
The Help menu is used to access the incorporated documentation and other features that provide information about the IDV.
  1. First, let's look at the User's Guide. Select the Help->User's Guide menu item to bring up the IDV User's Guide.
  2. You can select any topic in the navigation pane at the left side of the viewer. For example, expand the Appendix tab, then the Examples of Display Types tab and select the Flow Displays entry in the list to view that page.
  3. Now, use the Help->Zooming, Panning and Rotating menu item in the main menu bar of the IDV to go to the page that provides an overview of mouse and keyboard use. Show popup
  4. Close the IDV User's Guide window by clicking on the X in title bar of the window.
  5. Now, let's bring the Help Tips window back up by selecting the Help->Show Help Tips menu item. The help tips in this window are designed to give you some tips on using the IDV and quick access to sections of the User's Guide. Click the Next button until you get to the Zooming, Panning, and Rotating tip. Click on the link to bring up the User's Guide section on this topic.
  6. Uncheck the Show tips on startup checkbox and then click the Close button. The next time you start the IDV, the Help Tips window will not automatically pop up.
  7. There are several items in the Help menu that are useful if you are having problems and need to contact Unidata User Support. The Help->Show Console menu item brings up the IDV console where all error messages are shown. Another important menu is the Help->About... menu which lists the version of the IDV that you are running. You should always indicate the version when you contact Unidata User Support with any problems you may have. Lastly, if you are having problems with the IDV, the Help->Support Request Form... menu allows you to submit a problem report directly to Unidata. This should be used as a last resort after you have followed all the recommended steps in the User's Guide Documentation and Support. Be sure to fill in all the fields and most importantly to provide a detailed description of the problem.
Now, let's look at the View and Projections menus in the View Window.

 


Previous: Navigating (Zooming, Panning and Rotating) the View Window Next: The View and Projections Menus Table of contents Index Glossary Images Frames Français Español Portugese Italian Japanese Korean Russian Chinese-simp Chinese-trad Dutch German Greek Français Español Portugese Italian Japanese Korean Russian Chinese-simp Chinese-trad Dutch German Greek

U09-NRM-127: The role of Distributed Data Access Technologies in NRM - for ITC-IDV version 2.7 > Starting the IDV/GUI Basics > IDV Basic Concepts